EMMA PHISHING ALERT

Incident Report for Meevo

Resolved

This incident has been resolved.
Posted Aug 28, 2025 - 12:47 EDT

Investigating

Please be aware of any emails you receive claiming to be from Emma requesting that you sign in to your account to complete MFA/2FA. Logins to the application should only be done through your browser via www.myemma.com or your IT team's URL or a single sign-on process. Emma will not email you asking you to sign on.

Emma is aware of the phishing attempts and monitoring the situation.
Posted Jul 12, 2025 - 11:13 EDT
This incident affected: Meevo Integrations (EMMA/Meevo Marketing).