WorldPay Transaction Failures

Incident Report for Meevo

Resolved

Worldpay technical resources resolved an internal database issue to restore service. Worldpay stated they will continue to monitor the processing environment for stability, but have marked this as resolved.
Posted Aug 31, 2025 - 10:47 EDT

Identified

WorldPay is currently experiencing an incident affecting transaction authorizations. This may result in some transactions failing. Worldpay is currently working towards a resolution.
Posted Aug 31, 2025 - 09:25 EDT
This incident affected: Worldpay.