Worldpay Service Impact
Incident Report for Meevo
Resolved
Worldpay has communicated that any Service Impact should now be resolved! If you switched over to Hosted Page as a workaround please switch back to your normal Credit Card Device by following: https://docs.meevo.com/single-location/#t=MoreInfo%2FExecutingContingencyInternet.htm or contacting Business Support at (973) 402-8801. Otherwise, no additional action needed.
Posted May 06, 2022 - 12:23 EDT
Identified
Worldpay has identified an issue impacting processing services, and their technical resources are working to resolve the issue.

While the issue is being resolved by Worldpay, you can use the Hosted Page within Meevo to act as a Virtual Credit Card Terminal. Please see https://docs.meevo.com/single-location/MoreInfo/ExecutingContingencyInternet.htm or contact Millennium Business Support at (973) 402-8801 for assistance with configuring Hosted Page.

Any additional updates will be provided as information becomes available from Worldpay. We thank you for your patience and are here to work with you through this!
Posted May 06, 2022 - 10:42 EDT
Investigating
Clients using the Worldpay Processing Platform may experience delays or inability to complete transactions. Worldpay technical resources are working to identify and resolve the issue. Updates will be provided as information from Worldpay becomes available.
Posted May 06, 2022 - 10:33 EDT
This incident affected: Worldpay.