MeevoPay: Funding Delay

Incident Report for Meevo

Resolved

Resolved – The issue has been resolved. Disbursements for Monday’s delayed funds, as well as today's deposits for Tuesday's transactions, were processed today as expected. Please reach out to our Merchant Services team if you need further assistance - 973-402-9500 opt 5
Posted May 14, 2025 - 09:28 EDT

Identified

Update: We’ve identified the transmission issue causing the MeevoPay funding delay and funds are expected by the next business day. We sincerely apologize for the inconvenience and appreciate your continued patience as we worked to resolve the issue.
Posted May 13, 2025 - 14:07 EDT

Update

Update: Funding may be delayed a few hours. We will continue to provide updates as they come. Thank you for your patience!
Posted May 13, 2025 - 10:35 EDT

Investigating

We are currently investigating a potential delay in MeevoPay fund disbursements originally expected today, Tuesday May 13th, for transactions from Monday, May 12th. Our team is actively gathering information and working to process funds as quickly as possible. We will provide updates as soon as they become available. We apologize for any inconvenience and appreciate your patience.
Posted May 13, 2025 - 09:25 EDT
This incident affected: MeevoPay.