CardConnect Service Impact - Resolved
Incident Report for Meevo
Resolved
CardConnect has communicated that any Service Impact should now be resolved! No additional action needed, we thank you for your patience.
Posted Sep 15, 2022 - 15:44 EDT
Investigating
Clients using the CardConnect Processing Platform may experience delays or inability to complete transactions. CardConnect technical resources are working to identify and resolve the issue. Updates will be provided as information from CardConnect becomes available.
Posted Sep 15, 2022 - 12:09 EDT
This incident affected: CardConnect.