Worldpay Service Impact
Incident Report for Meevo
Resolved
Worldpay has communicated that any Service Impact should now be resolved! No additional action needed, however if you have any issues within Meevo please contact our Business Support at (973) 402-8801. Thank you!
Posted May 05, 2022 - 13:36 EDT
Investigating
Clients using the Worldpay Processing Platform may experience delays or inability to complete transactions. Worldpay technical resources are working to identify and resolve the issue. Updates will be provided as information from Worldpay becomes available.
Posted May 05, 2022 - 13:02 EDT
This incident affected: Worldpay.