MeevoPay MeevoXchange 1/12 Deposit Reporting

Incident Report for Meevo

Resolved

The information for the 1/12 deposit is now reflecting properly inside the MeevoXchange. Please reach out to our Merchant Services team at 973-402-9500 option 5 if you have any issues.
Posted Jan 15, 2026 - 09:35 EST

Investigating

We are aware of an issue when trying to view the deposit details for the deposit on Monday 1/12. We have confirmed funding did go through successfully. Our teams are working to fix the data not showing in the MeevoXchange.
Posted Jan 14, 2026 - 09:51 EST
This incident affected: MeevoPay.