MeevoPay - Partial Payout Delay

Incident Report for Meevo

Resolved

This issue has now been resolved. Customers impacted by delayed deposits can expect their payouts to arrive within 24 hours of the original delivery time.
Posted Apr 27, 2026 - 17:40 EDT

Identified

Our sponsor bank has identified an issue impacting some MeevoPay accounts, resulting in delayed deposits that were scheduled for 4/27. Their engineering teams have been engaged and are working to resolve this issue. We will provide an update on the expected delay as soon as we have more information.
Posted Apr 27, 2026 - 15:59 EDT
This incident affected: MeevoPay.