Intermittent Phone and Live Chat Issues

Incident Report for Meevo

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 17:56 EDT

Investigating

We are currently experiencing intermittent technical difficulties with our phone and live chat systems. Alternatively, you can reach us by emailing support@millenniumsi.com or joining our Facebook Community under Meevo > Help. Thank you, and we apologize for the inconvenience.
Posted Sep 16, 2026 - 08:04 EDT