Worldpay Investigating Service Impact
Incident Report for Meevo
Resolved
Worldpay has communicated that any VISA Service Impact should now be resolved! No additional action needed.
Posted Sep 23, 2022 - 22:48 EDT
Investigating
Clients using the Worldpay Processing Platform may experience delays or inability to complete VISA transactions. Worldpay technical resources are working to identify and resolve the issue. Updates will be provided as information from Worldpay becomes available.
Posted Sep 23, 2022 - 14:55 EDT
This incident affected: Worldpay.