WorldPay Funding Delay

Incident Report for Meevo

Resolved

From WorldPay:

A subset of ACH settlement files from October 11-13, 2025, were not processed as expected due to an issue at a third-party bank, resulting in a funding delay for some merchants.

Merchants receiving ACH files totalling less than $1M will receive funds today, but the deposit will occur later than the usual processing time.

Merchants being sent ACH files totalling more than $1M will receive their funds tomorrow, October 15 (federal guidelines do not allow same-day settlement over $1M).

Worldpay is working with the third-party bank in question to fully identify the root cause to help prevent similar recurrences.
Posted Oct 14, 2025 - 17:39 EDT

Identified

Update from WorldPay: Third-party technical resources continue to work to resolve the issue. All Worldpay systems are operating normally. Worldpay will continue to monitor the environment for recovery. Further updates will be provided as more information becomes available.
Posted Oct 14, 2025 - 12:03 EDT

Investigating

There is an incident which is causing a delay in Core Settlement for multiple Worldpay platforms. Worldpay technical resources are working to identify and resolve the issue.

Please be aware this does not affect MeevoPay or CardConnect processing. We will add any updates as WorldPay provides them.
Posted Oct 14, 2025 - 12:01 EDT
This incident affected: Worldpay.