MeevoPay Processing Outage

Incident Report for Meevo

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 11:03 EDT

Update

Update from our payments partner:

We are currently experiencing severely degraded performance for merchants. Our technical teams are actively working on urgently resolve this issue.
Posted Aug 21, 2025 - 10:44 EDT

Investigating

We are currently investigating reported issues with processing using MeevoPay devices. We apologize for any disruptions this may cause. Please try using Hosted Page in the meantime as we have seen success with this. Thank you for your patience while we work on this.
Posted Aug 21, 2025 - 10:06 EDT
This incident affected: MeevoPay.