Worldpay Service Impact on Visa Network
Incident Report for Meevo
Resolved
Visa technical resources have resolved an internal issue to restore service. Worldpay systems functioned normally throughout the incident. Worldpay will continue to monitor the environment for stability. Thank you for your patience!
Posted Sep 26, 2022 - 16:40 EDT
Identified
Visa technical resources have identified an internal issue and are working towards resolution. Worldpay systems are functioning normally. Updates will be provided as more information becomes available.
Posted Sep 26, 2022 - 13:12 EDT
Investigating
Worldpay and Visa technical resources are working to identify and resolve the issue. Worldpay systems are functioning normally. Clients using the Worldpay Processing Platform may experience delays or inability to complete Visa transactions. Updates will be provided as more information becomes available.
Posted Sep 26, 2022 - 12:56 EDT
This incident affected: Worldpay.