Receipt Printing on Google Chrome
Incident Report for Meevo
Resolved
This incident has been resolved.
Posted Apr 05, 2023 - 14:32 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 05, 2023 - 14:29 EDT
Update
We have a fix prepared for Epson receipt printers. If you have an Epson receipt printer and are still experiencing issues, please give us a call in Support to assist!

***************************************************************************************************************************

This has been corrected within a new firmware update provided to us by Epson and we wanted to provide some information on how this can be applied to your device. Below are links to download the new firmware update from Epson as well our user guide with step-by-step instructions on how to apply the update. As always, if you have any questions or need assistance, our support team can be reached at (973) 402-8801 or by emailing support@millenniumsi.com.

Epson Firmware:
https://download.epson-biz.com/modules/pos/index.php?page=single_soft&cid=6794&pcat=52&pid=5312

Meevo User Guide:
Firmware update: https://docs.meevo.com/single-location/Devices/FirmwareforEpsonReceiptPrinters.htm
Printer Installation: https://docs.meevo.com/single-location/Devices/EpsonT88VIi.htm
Posted Dec 22, 2022 - 09:00 EST
Identified
Many businesses have been experiencing difficulties with their receipt printers recently. You may experience receipts not printing, having to re-trust your receipt printer, and the Not Trusted message in your browser. This is due to a recent Google Chrome update. We are working with Google to find a more permanent resolution. In the interim, we have a few workarounds. If you need any help getting your receipts printed in the meantime, please give us a call in Support!

- Uninstall/reinstall Chrome (make sure to save your bookmarks and passwords)
- Retrust the printer as needed
- Use untrusted mode
- Other Browser
- Email Receipts
Posted Oct 24, 2022 - 09:00 EDT