WorldPay Processing Outage

Incident Report for Meevo

Resolved

Worldpay technical teams resolved an internal network issue to restore service. Worldpay will continue to monitor the environment for stability.
Posted Dec 02, 2025 - 14:54 EST

Identified

Worldpay technical teams have identified an internal network issue and are continuing to work to restore connectivity.
Posted Dec 02, 2025 - 12:05 EST

Investigating

WorldPay announced that there is an incident intermittently affecting transaction authorizations on the Integrated Payments platform. Some transactions may be intermittently declined. Worldpay technical resources are working to identify and resolve the issue.
Posted Dec 02, 2025 - 08:44 EST
This incident affected: Worldpay.