Worldpay Service Impact on Visa Network
Incident Report for Meevo
Resolved
Worldpay has communicated that any Service Impact should now be resolved! No further action should be needed.
Posted Sep 22, 2022 - 18:02 EDT
Identified
Visa technical resources has identified an issue impacting processing services, and working to resolve the issue. At this time no action needs to be taken, and updates will be provided as Worldpay identifies them.

We appreciate your patience and understanding!
Posted Sep 22, 2022 - 14:07 EDT
Investigating
Clients using the Worldpay Processing Platform may experience delays or inability to complete Visa transactions. Worldpay technical resources are working to identify and resolve the issue. Updates will be provided as information from Worldpay becomes available regarding the Visa Network.
Posted Sep 22, 2022 - 12:34 EDT
This incident affected: Worldpay.