Meevo Messenger - Error Message Accessing from Appointment Book
Incident Report for Meevo
Resolved
This incident has been resolved.
Posted Jun 05, 2023 - 07:00 EDT
Investigating
We are currently investigating this issue. You should be able to message your clients by going to Meevo > Integration > Messenger in the meantime.
Posted May 04, 2023 - 08:00 EDT
This incident affected: Meevo Integrations (Textel).