Textel/Meevo Messenger - Issues Sending or Receiving Messages
Incident Report for Meevo
Resolved
Textel does not control carrier blocks but they can help you get your line verified. All texting providers must abide by these guidelines which are ever-changing. If you are still having trouble sending or receiving messages, particularly for Verizon mobile users, you can email Textel at support@textel.net or call 844-483-9835.
Posted Nov 29, 2023 - 08:17 EST
Update
We are aware that some businesses that previously submitted their 10DLC registration through Textel may now be having trouble receiving messages from clients through Meevo Messenger. To remedy this, please contact Textel (email support@textel.net) to review your account, as you may need to resubmit your 10DLC form. Meevo Support can still create a ticket and go through troubleshooting to confirm there are no issues with your Meevo settings and configuration.
Posted Oct 18, 2023 - 18:12 EDT
Update
Textel does not control carrier blocks but they can help you get your line verified. All texting providers must abide by these guidelines which are ever-changing. You can email Textel at support@textel.net or call 844-483-9835.
Posted Dec 22, 2022 - 11:18 EST
Identified
On November 30th, mobile carriers (specifically Verizon) began enforcing the 10 Digit Long Code verification mandate which requires all businesses to register and verify their use case for their text line. The carrier can block the line if businesses are not registered and verified. Verizon is blocking all non-registered, non-verified lines from sending text messages from a landline number to their mobile customers.

Textel is not causing this directly, but they can help you to submit the appropriate forms. The form that must be completed must include the business EIN, legal and DBA name, the use case of the line, and a few more questions. Carriers are trying to mitigate scammers and protect us all from spam.

Textel does not control carrier blocks but they can help you get your line verified. All texting providers must abide by these guidelines which are ever-changing. You can email Textel at support@textel.net or call 844-483-9835.
Posted Nov 30, 2022 - 00:00 EST
This incident affected: Meevo Integrations (Textel).